FAC MERCHANT NOTIFICATION - MAINTENANCE - Republic Bank
Incident Report for FAC Republic Bank
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 00:40 UTC
Investigating
To our valued clients,

The Bank have advised that their systems will be undergoing a period maintenance during the following time period. During this period of maintenance, there will be an interruption to processing.

If you have any questions, please do not hesitate to contact us at support@fac.bm
Posted Aug 16, 2023 - 23:50 UTC
This incident affected: Republic Outage Merchants.